1. 程式人生 > >POJ 1458 Common Subsequence

POJ 1458 Common Subsequence

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

 設dp方程dp[i][j]表示到s1字串i位置的和到s2字串j位置的最長公共子串。

dp方程為:

i==j:

dp[i][j]=dp[i-1][j-1]+1;

i!=j

dp[i][j]=max(dp[i][j-1],dp[i-1][j])+1;

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=1005;
int dp[maxn][maxn];
char s1[maxn],s2[maxn];
int len1,len2;
void init()
{
    memset (dp,0,sizeof(dp));
    len1=strlen(s1);
    len2=strlen(s2);
}
int main()
{
    while (scanf("%s%s",&s1,&s2)!=EOF)
    {
        init();
        for (int i=0;i<len1;i++)
        {
            for (int j=0;j<len2;j++)
            {
                if(s1[i]==s2[j])
                {
                    dp[i+1][j+1]=dp[i][j]+1;
                }
                else
                {
                    dp[i+1][j+1]=max(dp[i+1][j],dp[i][j+1]);
                }
            }
        }
        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}