poj 3070 Fibonacci(矩陣快速冪模板,斐波那契)
Time Limit: 1000MS | Memory Limit: 65536K |
Total Submissions: 12812 | Accepted: 9109 |
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn
Sample Input
0 9 999999999 1000000000 -1
Sample Output
0 34 626 6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
題意:求f[n],f為斐波那契數列
思路:矩陣快速冪和一般的快速冪是一樣的,只是把普通的乘法改成矩陣乘法即可,可以當模板。
程式碼:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define mod 10000
struct Matrix
{
long long ma[2][2];
};
Matrix mul(Matrix A,Matrix B)
{
Matrix C;
C.ma[0][0]=C.ma[0][1]=C.ma[1][0]=C.ma[1][1]=0;
for(int i=0;i<2;i++)
{
for(int j=0;j<2;j++)
{
for(int k=0;k<2;k++)
{
C.ma[i][j]=(C.ma[i][j]+A.ma[i][k]*B.ma[k][j])%mod;
}
}
}
return C;
}
Matrix pow_mod(Matrix A,long long n)
{
Matrix B;
B.ma[0][0]=B.ma[1][1]=1;
B.ma[0][1]=B.ma[1][0]=0;
while(n)
{
if(n&1) B=mul(B,A);
A=mul(A,A);
n>>=1;
}
return B;
}
int main()
{
long long n;
while(~scanf("%lld",&n)&&n!=-1)
{
Matrix A;
A.ma[0][0]=1;A.ma[0][1]=1;
A.ma[1][0]=1;A.ma[1][1]=0;
Matrix ans=pow_mod(A,n);
printf("%lld\n",ans.ma[0][1]);
}
return 0;
}