Fibonacci (矩陣快速冪)
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn
Sample Input
0 9 999999999 1000000000 -1
Sample Output
0 34 626 6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
PS:基本的矩陣快速冪
#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
const int maxn=1000000;
const int mod=10000;
#define me(a) memset(a,0,sizeof(a))
#define ll long long
using namespace std;
struct node{
int a[2][2];
node()
{
memset(a,0,sizeof(a));
}
};
node jx(node a,node b)
{
node s;
for(int i=0;i<2;i++)
for(int j=0;j<2;j++)
for(int k=0;k<2;k++)
s.a[i][k]=(s.a[i][k]+a.a[i][j]*b.a[j][k])%mod;
return s;
}
node qsort(node a,int n)
{
node s;
for(int i=0;i<2;i++)
s.a[i][i]=1;
while(n)
{
if(n&1)
s=jx(s,a);
a=jx(a,a);
n>>=1;
}
return s;
}
int main()
{
node a;
int n;
a.a[0][0]=a.a[1][0]=a.a[0][1]=1;
while(cin>>n&&n!=-1)
{
node s=qsort(a,n);
cout<<s.a[1][0]<<endl;
}
return 0;
}
。