1. 程式人生 > >Aizu-ALDS1_3_A:Stack

Aizu-ALDS1_3_A:Stack

D - Stack

Write a program which reads an expression in the Reverse Polish notation and prints the computational result.
An expression in the Reverse Polish notation is calculated using a stack. To evaluate the expression, the program should read symbols in order. If the symbol is an operand, the corresponding value should be pushed into the stack. On the other hand, if the symbols is an operator, the program should pop two elements from the stack, perform the corresponding operations, then push the result in to the stack. The program should repeat this operations.

Input

An expression is given in a line. Two consequtive symbols (operand or operator) are separated by a space character.
You can assume that +, - and * are given as the operator and an operand is a positive integer less than 106

Output

Print the computational result in a line.

Constraints

2 ≤ the number of operands in the expression ≤ 100
1 ≤ the number of operators in the expression ≤ 99
-1 × 109 ≤ values in the stack ≤ 109

Sample Input 1

1 2 +

Sample Output 1

3

Sample Input 2

1 2 + 3 4 - *

Sample Output 2

-3

解題心得:

  1. 給出的輸入很簡單已經是一個逆波蘭表示法了,只要寫一個棧來模擬一下運算的過程。
  2. 如果輸入的是四則運算子號,就從棧中取出兩個數字運算,得出的結果壓入棧,如果輸入的直接就是數字,就直接壓入棧。
#include<bits/stdc++.h>
using namespace std;
string s;
int main()
{
    stack <long long> st;
    while(cin>>s)
    {
        if(s[0]>='0' && s[0] <= '9')
        {
            long long num = 0;
            for(int i=0;i<s.length();i++)
            {
                long long temp = (s[i]-'0');
                num = num*10+temp;
            }
            st.push(num);
        }
        else
        {
            long long a,b;
            b = st.top();
            st.pop();
            a = st.top();
            st.pop();
            if(s[0] == '*')
                a = a*b;
            else if(s[0] == '+')
                a = a+b;
            else if(s[0] == '-')
                a = a-b;
            else if(s[0] == '/')
                a = a/b;
            st.push(a);
        }
    }
    long long ans = st.top();
    st.pop();
    printf("%lld\n",ans);
    return 0;
}