1. 程式人生 > >【笨方法學PAT】1122 Hamiltonian Cycle (25 分)

【笨方法學PAT】1122 Hamiltonian Cycle (25 分)

一、題目

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2

, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

二、題目大意

給定規則,判斷是否符合。

三、考點

陣列

四、注意

1、針對每一條規則,逐一判斷。

五、程式碼

#include<iostream>
#include<vector>
#define N 201
using namespace std;
int main() {
	//read
	int n, m;
	cin >> n >> m;
	int e[N][N] = { 0 };
	for (int i = 0; i < m; ++i) {
		int a, b;
		cin >> a >> b;
		e[a][b] = e[b][a] = 1;
	}

	//every query
	cin >> m;
	for (int i = 0; i < m; ++i) {
		bool flag = true;
		int k;
		cin >> k;

		//number
		if (k != n + 1)
			flag = false;
		
		vector<int> v(k);
		vector<bool> show(N,false);
		for (int j = 0; j < k; ++j) {
			cin >> v[j];
			if (j == 0)
				continue;
			show[v[j]] = true;
		}

		//begin and end
		if (v[0] != v[k - 1])
			flag = false;

		//link
		for (int j = 0; j < k-1; ++j) {
			if (e[v[j]][v[j + 1]] == 0) {
				flag = false;
				break;
			}
		}

		//show
		for (int j = 1; j <= n; ++j) {
			if (show[j] == false) {
				flag = false;
				break;
			}
		}

		//output
		if (flag == false)
			cout << "NO" << endl;
		else
			cout << "YES" << endl;
	}

	system("pause");
	return 0;
}