1. 程式人生 > >HDU 1501 Zipper (DFS)

HDU 1501 Zipper (DFS)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9922    Accepted Submission(s): 3553


Problem Description Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.


Output For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input 3 cat tree tcraete cat tree catrtee cat tree cttaree
Sample Output Data set 1: yes Data set 2: yes Data set 3: no
Source

題意:

給出三個字串,前兩個字串的長度之和等於第三個字串的長度,問是否能在第三個字串內按其邏輯順序找到前兩個字串。

程式碼如下:

#include<cstdio>
#include<cstring>
char str1[550],str2[550],str3[550];
int i,j,k;
int len1,len2,len3;
int vis[550][550];
int dfs(int i,int j,int k)
{
	if(k==len3)
	return 1;
     if(vis[i][j])//剪枝避免超時 
    return 0;
    vis[i][j]=1;
    if(str1[i]==str3[k]&&dfs(i+1,j,k+1))
      return 1;
    if(str2[j]==str3[k]&&dfs(i,j+1,k+1))
      return 1;
	return 0;
}
int main()
{
	int t;
	scanf("%d",&t);
	int k=1;
	while(t--)
	{
		memset(vis,0,sizeof(vis));
		scanf("%s%s%s",str1,str2,str3);
		 len1=strlen(str1);
		 len2=strlen(str2);
	       len3=strlen(str3);
		printf("Data set %d: ",k++);
		if(dfs(0,0,0))
		  printf("yes\n");
		else
		  printf("no\n");
	}
	return 0;
}