1. 程式人生 > >Newcoder 4 A.Contest(逆序對-BIT)

Newcoder 4 A.Contest(逆序對-BIT)

Description

n n 支隊伍一共參加了三場比賽。

一支隊伍 x x 認為自己比另一支隊伍 y

y 強當且僅當 x x 在至少一場比賽中比 y y 的排名高。

求有多少組 (

x , y ) (x,y) ,使得 x x 自己覺得比 y
y
強, y y 自己也覺得比 x x 強。

$ (x, y), (y, x)$算一組。

Input

第一行一個整數 n n ,表示隊伍數; 接下來 n n 行,每行三個整數 a [ i ] , b [ i ] , c [ i ] a[i], b[i], c[i] ,分別表示 i i 在第一場、第二場和第三場比賽中的名次; n n 最大不超過 200000 200000

Output

輸出一個整數表示滿足條件的 ( x , y ) (x,y) 數; 64 b i t 64bit 請用 l l d lld

Sample Input

4
1 3 1
2 2 4
4 1 2
3 4 3

Sample Output

5

Solution

( x , y ) (x,y) 之間必然是 x x 兩敗一勝或兩勝一敗,考慮因 a , b , c a,b,c 其中之一敗因 a , b , c a,b,c 其中另一勝的二元組個數之和(即二元組逆序對個數),那麼一組合法解 ( x , y ) (x,y) 會被計算四次,所求答案除以四即為答案,時間複雜度 O ( n l o g n ) O(nlogn)

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=200005;
struct BIT 
{
	#define lowbit(x) (x&(-x))
	int b[maxn],n;
	void init(int _n)
	{
		n=_n;
		for(int i=1;i<=n;i++)b[i]=0;
	}
	void update(int x,int v)
	{
		while(x<=n)
		{
			b[x]+=v;
			x+=lowbit(x);
		}
	}
	int query(int x)
	{
		int ans=0;
		while(x)
		{
			ans+=b[x];
			x-=lowbit(x);
		}
		return ans;
	}
}bit;
int n,x[3][maxn];
P a[maxn];
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)scanf("%d%d%d",&x[0][i],&x[1][i],&x[2][i]);
	ll ans=0;
	for(int i=0;i<3;i++)
		for(int j=0;j<3;j++)
			if(i!=j)
			{
				for(int k=1;k<=n;k++)a[k]=P(x[i][k],x[j][k]);
				sort(a+1,a+n+1);
				bit.init(n);
				for(int k=n;k>=1;k--)
				{
					ans+=bit.query(a[k].second);
					bit.update(a[k].second,1);
				}
			}
	printf("%lld\n",ans/4);
	return 0;
}