Newcoder 4 A.Contest(逆序對-BIT)
阿新 • • 發佈:2018-12-30
Description
支隊伍一共參加了三場比賽。
一支隊伍 認為自己比另一支隊伍 強當且僅當 在至少一場比賽中比 的排名高。
求有多少組 ,使得 自己覺得比 強, 自己也覺得比 強。
$ (x, y), (y, x)$算一組。
Input
第一行一個整數 ,表示隊伍數; 接下來 行,每行三個整數 ,分別表示 在第一場、第二場和第三場比賽中的名次; 最大不超過
Output
輸出一個整數表示滿足條件的 數; 請用
Sample Input
4
1 3 1
2 2 4
4 1 2
3 4 3
Sample Output
5
Solution
之間必然是 兩敗一勝或兩勝一敗,考慮因 其中之一敗因 其中另一勝的二元組個數之和(即二元組逆序對個數),那麼一組合法解 會被計算四次,所求答案除以四即為答案,時間複雜度
Code
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=200005;
struct BIT
{
#define lowbit(x) (x&(-x))
int b[maxn],n;
void init(int _n)
{
n=_n;
for(int i=1;i<=n;i++)b[i]=0;
}
void update(int x,int v)
{
while(x<=n)
{
b[x]+=v;
x+=lowbit(x);
}
}
int query(int x)
{
int ans=0;
while(x)
{
ans+=b[x];
x-=lowbit(x);
}
return ans;
}
}bit;
int n,x[3][maxn];
P a[maxn];
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)scanf("%d%d%d",&x[0][i],&x[1][i],&x[2][i]);
ll ans=0;
for(int i=0;i<3;i++)
for(int j=0;j<3;j++)
if(i!=j)
{
for(int k=1;k<=n;k++)a[k]=P(x[i][k],x[j][k]);
sort(a+1,a+n+1);
bit.init(n);
for(int k=n;k>=1;k--)
{
ans+=bit.query(a[k].second);
bit.update(a[k].second,1);
}
}
printf("%lld\n",ans/4);
return 0;
}