1. 程式人生 > >POJ3660解題報告-Floyd解決傳遞閉包

POJ3660解題報告-Floyd解決傳遞閉包

A - Cow ContestTime Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u use MathJax to parse formulas

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

求解:經過m場比賽後,n頭牛中有多少頭牛可以確定它的排名

解析:當且僅當一頭牛打贏了a頭牛,輸給了b頭牛,且a+b=n-1時,它的排名可以被確定

程式碼如下:

#include <iostream>
#include<stdio.h>
using namespace std;
const int N=100+5;
const int MAX=0x3f3f3f3f;
int n,m;	//n頭牛,m場比賽
int mapa[N][N];		
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)	//mapa陣列初始化
            {
                if(i==j)
                    mapa[i][j]=0;
                else
                    mapa[i][j]=MAX;
            }
        for(int i=1;i<=m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            mapa[a][b]=1;		//第a頭牛打敗了第b頭牛
        }
        int sum=0;
        for(int k=1;k<=n;k++)		//Floyd求解傳遞閉包
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    if(mapa[i][k]==1&&mapa[k][j]==1)	//如果i打敗了k,k打敗了j,則相當於i打敗了j
                    {
                        mapa[i][j]=1;
                    }

        for(int i=1;i<=n;i++)
        {
            int s=0;
            for(int j=1;j<=n;j++)
            {
                if(mapa[i][j]==1||mapa[j][i]==1)	//i,j之間可以確定勝負關係
                    s++;
            }
            if(s==n-1)
                sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}