1. 程式人生 > >dfs_1064 Complete Binary Search Tree (30 分)

dfs_1064 Complete Binary Search Tree (30 分)

1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

題目大意

題目要求給定一個數組,給出這個陣列所組成的完全二叉搜尋樹的層次遍歷序列

二叉搜尋樹,左邊的節點小於當前節點數值,右邊節點大於當前節點數值,並且左子樹右子樹也是滿足上面的兩個條件

使用深搜,按照中序遍歷的方式給樹對應的位置上進行賦值

然後按照順序輸出二叉樹的陣列即可

#include <vector>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f

using namespace std;
const int maxn = 1005;
int a[maxn],tree[maxn*2],_index,n;

void dfs(int p)
{
    if(p > n)
        return ;
    dfs(p<<1);
    tree[p] = a[_index++];
    dfs(p<<1|1);
}
int main()
{
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
        scanf("%d",a+i);
    sort(a,a+n);
    dfs(1);
    for(int i =1 ;i <= n;i ++)
        printf("%d%c",tree[i],i==n?'\n':' ');
    return 0;
}