1. 程式人生 > >棧stacks(先進後出)

棧stacks(先進後出)

Rails

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

題意:有一列火車,車廂編號為1到n,只能由一段進站,另一端出站。現在進站順序確定:1,2,3,4...n,給出一個出站的順序,判斷出站順序是否可能。

思路:其實就是一個模擬棧的過程,先進後出。但是由於會出現這樣的情況,比如說:1 2 3進棧,然後3出棧,然後4 5進棧,所以該出棧的順序是3 5 4 2 1,所以在模擬的過程中需要注意一下。

還有就是注意一下最後輸入0的時候沒有換行,所以需要特殊處理一下。

#include <cstdio>  
#include <stack>  
using namespace std;  
const int maxn=1000+5;  
int a[maxn];  
int main()  
{  
    int n,i,k;  
    while(scanf("%d",&n)&&n)  
    {  
        stack<int>s;//設立一個棧儲存按順序進棧的序列 (一個空棧)  
        while(scanf("%d",&a[0])&&a[0])  
        {  
            for(i=1;i<n;i++)  
                scanf("%d",&a[i]);//要進行判斷出棧的序列  
            for(i=1,k=0;i<=n;i++)  
            {  
                s.push(i);//進棧  
                while(s.top()==a[k])//判斷棧頂元素和a陣列是否相等  
                {  
                    if(!s.empty()) s.pop();//棧不為空就出棧  
                    k++;//判斷下一個位置  
                    if(s.empty()) break;//直到棧空就結束迴圈  
                }  
            }  
            if(k==n) printf("Yes\n");//完全匹配就輸出yes  
           else printf("No\n");  
        }  
        printf("\n");  
    }  
    return 0;  
}