UVALive8091 Happy Number【數學】
Consider the following function f defined for any natural number n:
f(n) is the number obtained by summing up the squares of the digits of n in decimal (or base-ten).
If n = 19, for example, then f(19) = 82 because 1^2 + 9^2 = 82.
Repeatedly applying this function f, some natural numbers eventually become 1. Such numbers are called happy numbers. For example, 19 is a happy number, because repeatedly applying function to 19 results in:
f(19) = 1^2 + 9^2 = 82
f(82) = 8^2 + 2^2 = 68
f(68) = 6^2 + 8^2 = 100
f(100) = 12 + 02 + 02 = 1
However, not all natural numbers are happy. You could try 5 and you will see that 5 is not a happy number. If n is not a happy number, it has been proved by mathematicians that repeatedly applying function f to n reaches the following cycle:
4 → 16 → 37 → 58 → 89 → 145 → 42 → 20 → 4.
Write a program that decides if a given natural number n is a happy number or not.
Input
The input file contains several test cases, each of them consists of a single line that contains an integer, n (1 ≤ n ≤ 1, 000, 000, 000)
Output
For each test case, print exactly one line. If the given number n is a happy number, print out ‘HAPPY’; otherwise, print out ‘UNHAPPY’.
Sample Input
19
5
Sample Output
HAPPY
UNHAPPY
問題簡述:(略)
問題分析: 某一個正整數n,對其各位數字分別平方再求和得到一個新數,重複同樣的計算,最終和變成1,則稱n為快樂數;如果出現迴圈變不成1則不是快樂數。
程式說明:
使用set來判重複是一個好做法。
函式ishn()是CV來的,其中包含統計步數的邏輯,參見參考連結。
題記:(略)
AC的C++語言程式如下:
/* UVALive8091 Happy Number */
#include <bits/stdc++.h>
using namespace std;
int ishn(int n) {
set<int> s;
int step = 1;
while (n != 1) {
step++;
int sum = 0;
while (n) {
int d = n % 10;
sum += d * d;
n /= 10;
}
n = sum;
if (s.count(n)) break;
else s.insert(n);
}
return n == 1 ? step : 0;
}
int main()
{
int n;
while(~scanf("%d", &n))
printf("%s\n", ishn(n) ? "HAPPY" : "UNHAPPY");
return 0;
}