1. 程式人生 > >每日三題-Day5-A(POJ 2533 Longest Ordered Subsequence 最長上升子序列O(nlogn)解法)

每日三題-Day5-A(POJ 2533 Longest Ordered Subsequence 最長上升子序列O(nlogn)解法)

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 51451 Accepted: 22885

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK
 <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

相似的題已經發過很多,裸的LIS也不難。不再累述。

可以參考這個題的題解:

http://blog.csdn.net/lulu11235813/article/details/70312914

AC程式碼:

#include<cstdio>
#include<cstring>

using namespace std;
int num[1005];
int min_end[1005];

int Bsea(int l,int r,int a)
{
    if(l>=r) return l;
    int mid=(l+r)/2;
    if(min_end[mid]>=a) return Bsea(l,mid,a);
    return Bsea(mid+1,r,a);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d",&num[i]);
        }
        int ans=1;
        min_end[1]=num[0];
        for(int i=1;i<n;i++)
        {
            if(num[i]>min_end[ans])
            {
                ans++;
                min_end[ans]=num[i];
            }
            else
            {
                min_end[Bsea(1,ans,num[i])]=num[i];
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}