1. 程式人生 > >POJ1251 ZOJ1406 HDU1301 UVALive2539 Jungle Roads【Kruskal演算法+並查集】

POJ1251 ZOJ1406 HDU1301 UVALive2539 Jungle Roads【Kruskal演算法+並查集】

Time Limit:1000MSMemory Limit:10000K
Total Submissions:30648Accepted:14347

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

Source


問題描述:(略)

問題分析

  這是一個最小生成樹的為問題,解決的演算法有Kruskal(克魯斯卡爾)演算法和Prim(普里姆) 演算法。

程式說明

  本程式使用Kruskal演算法實現。有關最小生成樹的問題,使用克魯斯卡爾演算法更具有優勢,只需要對所有的邊進行排序後處理一遍即可。程式中使用了並查集,用來判定加入一條邊後會不會產生迴圈。程式中,圖採用邊列表的方式儲存,排序一下就好了。

  這個題的時間問題並不突出,用C++的輸入輸出也可以通過。

AC的C++語言程式如下:

/* POJ1251 ZOJ1406 HDU1301 UVALive2539 Jungle Roads */

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 26;

int f[N + 1];

void UFInit(int n)
{
    for(int i = 1; i <=n; i++)
        f[i] = i;
}

int Find(int a) {
    return a == f[a] ? a : f[a] = Find(f[a]);
}

bool Union(int a, int b)
{
    a = Find(a);
    b = Find(b);
    if (a != b) {
        f[a] = b;
        return true;
    } else
        return false;
}

struct Edge {
    int u, v, w;
} edges[N * (N - 1)];

bool cmp(Edge a, Edge b)
{
    return a.w < b.w;
}

int main()
{
    int n, m, d, cnt2;
    char start, end;
    while(cin >> n && n) {
        UFInit(N);

        cnt2 = 0;
        for(int i = 0; i < n - 1; i++) {
            cin >> start >> m;
            for(int j = 1; j <= m; j++) {
                cin >> end >> d;
                edges[cnt2].u = start - 'A' + 1;
                edges[cnt2].v = end - 'A' + 1;
                edges[cnt2++].w = d;
            }
        }

            // Kruscal演算法
            int ans = 0;
            sort(edges, edges + cnt2, cmp);
            for(int i = 0; i < cnt2; i++)
                if(Union(edges[i].u, edges[i].v))
                    ans += edges[i].w;

            // 輸出結果
            cout << ans << endl;
    }

    return 0;
}