1. 程式人生 > >HDU1796(數論,容斥原理)

HDU1796(數論,容斥原理)

也是容斥原理的應用,這篇部落格用了DFS,比較明晰。原文地址:
http://www.cnblogs.com/jackge/archive/2013/04/03/2997169.html

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6745    Accepted Submission(s): 1957


Problem Description   Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input   There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output   For each case, output the number.
Sample Input 12 2 2 3
Sample Output 7
Author wangye
Source


題目大意:給定n和一個大小為m的集合,集合元素為非負整數。為1...n內能被集合裡任意一個數整除的數字個數。n<=2^31,m<=10



解題思路:容斥原理地簡單應用。先找出1...n內能被集合中任意一個元素整除的個數,再減去能被集合中任意兩個整除的個數,即能被它們兩隻的最小公倍數整除的個數,因為這部分被計算了兩次,然後又加上三個時候的個數,然後又減去四個時候的倍數...所以深搜,最後判斷下集合元素的個數為奇還是偶,奇加偶減。


#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <string>
#include <algorithm>
#include <string>
#include <set>
#include <iostream>

using namespace std;

#define MAXN 25
#define LEN 1000000
#define INF 1e9+7
#define MODE 1000000
typedef long long ll;

ll n,cnt=0;
ll ans=0;
int m;
int a[MAXN];
int que[LEN];

int gcd(int a,int b)
{
    if(b==0)
        return a;
    else
        return gcd(b,a%b);
}

void DFS(int cur,long long lcm,int id){
    lcm=a[cur]/gcd(a[cur],lcm)*lcm;
    if(id&1)
        ans+=(n-1)/lcm;     //因為這題並不包含n本身,所以用n-1
    else
        ans-=(n-1)/lcm;
    for(int i=cur+1;i<cnt;i++)
        DFS(i,lcm,id+1);
}


int main(){
    while(~scanf("%d%d",&n,&m)){
        cnt=0;
        int x;
        while(m--){
            scanf("%d",&x);
            if(x!=0)
                a[cnt++]=x;
        }
        ans=0;
        for(int i=0;i<cnt;i++)
            DFS(i,a[i],1);
        cout<<ans<<endl;
    }
    return 0;
}