1. 程式人生 > >hdu1258 被簡單搜尋坑了

hdu1258 被簡單搜尋坑了

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2918    Accepted Submission(s): 1461


Problem Description Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input 4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
Sample Output Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int bg[15],a[15],n,t,biaoji;

void dfs(int i,int k,int m)
{
	int j;
	if(m+a[i]<t)
	{
		bg[k]=a[i];
		for(j=i+1;j<=n;j++)
		{
			dfs(j,k+1,m+a[i]);
			while(j+1<=n&&a[j]==a[j+1])     //第二個去重複的迴圈
				j++;
		}
	}
	else
	{
		if(m+a[i]==t)
		{
			biaoji=1;
			bg[k]=a[i];
			printf("%d",bg[1]);
			for(j=2;j<=k;j++)
				printf("+%d",bg[j]);
			printf("\n");
			/*for(i=1;i<=n;i++)
				printf("%d ",la[i]);
			printf("\n");*/
		}
	}
}

int main()
{
	int i;
	while(scanf("%d%d",&t,&n)>0,n)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		printf("Sums of %d:\n",t);
		biaoji=0;
		for(i=1;i<=n;i++)
		{
			dfs(i,1,0);
			while(i+1<=n&&a[i]==a[i+1])    //第一個去重複的迴圈
				i++;
		}
		if(biaoji==0) printf("NONE\n");
	}
	return 0;
}

只要兩個去重複的迴圈給上,這就是一道簡單的深搜水題