1. 程式人生 > >計算球體積 (hdu2002)

計算球體積 (hdu2002)

2002 計算球體積

Problem Description 根據輸入的半徑值,計算球的體積。Input 輸入資料有多組,每組佔一行,每行包括一個實數,表示球的半徑。Output 輸出對應的球的體積,對於每組輸入資料,輸出一行,計算結果保留三位小數。Sample Input 1
1.5

Sample Output

4.189
14.137

程式碼:
#include<stdio.h>
#include<math.h>
#define PI 3.1415927
int main()
{
	double r,v;
	while(scanf("%lf",&r)!=EOF)
	{
		v = 0;
		v = 4*PI*r*r*r/3;
		printf("%.3lf\n",v);
	}
	return 0;
}