1. 程式人生 > >Just a Hook(線段樹 )

Just a Hook(線段樹 )

Just a Hook

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 36   Accepted Submission(s) : 14
Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input 1 10 2 1 5 2 5 9 3
Sample Output Case 1: The total value of the hook is 24.
Source 2008 “Sunline Cup” National Invitational Contest

線段樹功能:update:成段替換 (由於只query一次總區間,所以可以直接輸出1結點的資訊)

程式碼:

#include <iostream>
#include <stdio.h>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm> 
using namespace std;
const int maxn=100000+10;
int n,sum;
struct node{     //
	int l,r;
	int n;
}a[maxn<<2];
void build(int l,int r,int i)  //建樹
{
	a[i].l=l;
	a[i].r=r;
	a[i].n=1;
	if(l!=r)
	{
		int mid=(l+r)>>1;
		build(l,mid,2*i);
		build(mid+1,r,2*i+1);
	}
}
void update(int i,int x,int y,int m)  //更新區間值
{
	if(a[i].n==m)return;   //相同就不用修改
	if(a[i].l==x&&a[i].r==y) //找到了區間,直接進行更新
	{
		a[i].n=m;
		return;
	}
	if(a[i].n!=-1) //該區間只有一個值的情況
	{
		a[2*i].n=a[2*i+1].n=a[i].n;//由於後面必定對子樹操作,所以更新子樹的值等於父親的值
a[i].n=-1;//由於該區域顏色與修改不同,而且不是給定區域,所以該區域必定為雜色 }
       //父區間為雜色時對所有子節點進行操作
	int mid=(a[i].l+a[i].r)>>1;
	if(x>mid)
	update(2*i+1,x,y,m);
	else if(y<=mid)
	update(2*i,x,y,m);
	else
	{
		update(2*i,x,mid,m);
		update(2*i+1,mid+1,y,m);
	}
} 
int query(int i)  //查詢某一結點所包含的結果的值的和
{
	if(a[i].n!=-1)
	return (a[i].r-a[i].l+1)*a[i].n;
	else
	return query(2*i)+query(2*i+1); 
}
int main()
{
	ios::sync_with_stdio(false); //不加這句話會超時
	int t,i,k,x,y,m;
	int cas=1;
	cin>>t;
	while(t--)
	{
		cin>>n>>k;
		build(1,n,1);
		while(k--)
		{
			cin>>x>>y>>m;
			update(1,x,y,m);
			
		}
		 printf("Case %d: The total value of the hook is %d.\n",cas++,query(1)); 
	}

}

#include <cstdio>  
#include <algorithm>  
using namespace std;  
   
#define lson l , m , rt << 1  
#define rson m + 1 , r , rt << 1 | 1  
const int maxn = 111111;  
int h , w , n;  
int col[maxn<<2];  
int sum[maxn<<2];  
void PushUp(int rt) {  
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];  
}  
void PushDown(int rt,int m) {  
    if (col[rt]) {  
        col[rt<<1] = col[rt<<1|1] = col[rt];  
        sum[rt<<1] = (m - (m >> 1)) * col[rt];  
        sum[rt<<1|1] = (m >> 1) * col[rt];  
        col[rt] = 0;  
    }  
}  
void build(int l,int r,int rt) {  
    col[rt] = 0;  
    sum[rt] = 1;  
    if (l == r) return ;  
    int m = (l + r) >> 1;  
    build(lson);  
    build(rson);  
    PushUp(rt);  
}  
void update(int L,int R,int c,int l,int r,int rt) {  
    if (L <= l && r <= R) {  
        col[rt] = c;  
        sum[rt] = c * (r - l + 1);  
        return ;  
    }  
    PushDown(rt , r - l + 1);  //當前節點資訊傳遞子節點
    int m = (l + r) >> 1;  
    if (L <= m) update(L , R , c , lson);  
    if (R > m) update(L , R , c , rson);  
    PushUp(rt);  
}  
int main() {  
    int T , n , m;  
    scanf("%d",&T);  
    for (int cas = 1 ; cas <= T ; cas ++) {  
        scanf("%d%d",&n,&m);  
        build(1 , n , 1);  
        while (m --) {  
            int a , b , c;  
            scanf("%d%d%d",&a,&b,&c);  
            update(a , b , c , 1 , n , 1);  
        }  
        printf("Case %d: The total value of the hook is %d.\n",cas , sum[1]);  
    }  
    return 0;  
}