POJ 2481 Cows(樹狀陣列:區間真子集的個數)
Cows
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 23460 | Accepted: 7898 |
Description
Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.
Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].
But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.
For each cow, how many cows are stronger than her? Farmer John needs your help!
Input
The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.
The end of the input contains a single 0.
Output
For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.
Sample Input
3 1 2 0 3 3 4 0
Sample Output
1 0 0
Hint
Huge input and output,scanf and printf is recommended.
Source
題意:求一個區間真子集的個數。
分析:陣列陣列只能實現單點查詢,所以這題需要轉化一下
首先,我們先對區間進行排序,按照e的位置從大到小排序,e相同,按照s,從小到大排序,陣列陣列標記s。
然後,我們按照順序列舉,我們保證了e大的在前面,所以只要在樹狀陣列s比它小的即可,表示比i強壯,但是有一個坑點,真子集,如果相同的話不算真子集,所以需要判斷一下,直接令當前等於前一個即可。
這題核心就是排序後的數後面的不可能比前面的強壯。
#include<stdio.h>
#include<string>
#include<string.h>
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
const int MAXN=200000+5;//最大元素個數
int n;//元素個數
ll c[MAXN],ans[MAXN];//c[i]==A[i]+A[i-1]+...+A[i-lowbit(i)+1]
struct node{
int s,e,index;
}a[MAXN];
//返回i的二進位制最右邊1的值
int lowbit(int i)
{
return i&(-i);
}
//返回A[1]+...A[i]的和
ll sum(int x){
ll sum = 0;
while(x){
sum += c[x];
x -= lowbit(x);
}
return sum;
}
//令A[i] += val
void add(int x, ll val){
while(x <= n){
c[x] += val;
x += lowbit(x);
}
}
bool cmp(const node&a,const node &b)
{
if(a.e!=b.e)
return a.e>b.e;
else
return a.s<b.s;
}
int main()
{
while(scanf("%d",&n)!=-1&&n)
{
memset(c,0,sizeof(c));
memset(ans,0,sizeof(ans));
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a[i].s,&a[i].e);
a[i].s++; ///陣列陣列儲存下標從1開始
a[i].e++;
a[i].index=i;
}
sort(a+1,a+n+1,cmp);
ans[a[1].index]=0;
add(a[1].s,1);
for(int i=2;i<=n;i++)
{
if(a[i].s==a[i-1].s&&a[i].e==a[i-1].e)
ans[a[i].index]=ans[a[i-1].index];
else
ans[a[i].index]=sum(a[i].s);
add(a[i].s,1);
}
for(int i=1;i<n;i++)
{
printf("%d ",ans[i]);
}
cout<<ans[n]<<endl;
}
return 0;
}