1. 程式人生 > >POJ1013稱硬幣【枚舉】

POJ1013稱硬幣【枚舉】

careful table diff rip The 就是 represent poj 每次

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 52474 Accepted: 16402

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up‘‘, ``down‘‘, or ``even‘‘. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

Source

East Central North America 1998 大概意思就是有12枚硬幣從A到L,其中有一枚是假幣,但是不知道輕重。稱了三次,每次給定左邊硬幣和右邊硬幣以及右邊天秤的情況,三次稱量一定會確定一枚假幣,問哪個硬幣是假的並說明假幣輕了還是重了。 思路:把十二枚硬幣的情況都枚舉一遍,一枚硬幣如果是假幣會有是輕假幣還是重假幣的情況,都需要枚舉出來。從A到L依次假設為假幣,看是否符合三次稱量,因為只有一個假幣,所以肯定只有一個硬幣是假幣時,才會滿足給出的三次測量的情形。
#include<iostream>
#include<string.h>
using namespace std;
char cleft[3][7];//一共12個硬幣,每次一邊最多6個
char cright[3][7];
char result[3][7]; 
int num;
bool isFake(char c,bool heavy);//不加括號體 
int main()
{

	cin >> num;
	while(num-- !=0)
	{
		for(int i = 0;i<3;i++)
		{
			cin >> cleft[i] >>cright[i]>>result[i];
		}
		for(char i = ‘A‘;i<=‘L‘;++i)
		{
			if(isFake(i,true))
			{
				cout <<i<<" is the counterfeit coin and it is heavy. "<<endl;
				break;
			}
			else if(isFake(i,false))
			{
				cout <<i<<" is the counterfeit coin and it is light. "<<endl;
				break;
			}
		}
	}
	return 0;
}

bool isFake(char c,bool heavy)
{
	for(int i = 0;i<3;++i)
	{
		switch(result[i][0])
		{
			case ‘u‘:
				if(heavy == true && strchr(cleft[i],c)==NULL )//重 假幣肯定在左邊
						return false;
				if(heavy == false && strchr(cright[i],c)==NULL )//輕 假幣肯定在右邊
						return false;
				break;		
			case ‘d‘:
				if(heavy == true && strchr(cright[i],c)==NULL )//假幣肯定在右邊,並且重 
						return false;
				if(heavy == false && strchr(cleft[i],c)==NULL )//假幣肯定在左邊,並且輕 
						return false;
				break;		
			case ‘e‘:
				if(strchr(cleft[i],c)!=NULL || strchr(cright[i],c)!=NULL  )//假幣不在兩邊 
						return false;
				break;	
		}
	}
	return true;
}

strchr語法:
#include <string.h>
char *strchr( const char *str, int ch );
功能:函數返回一個指向str 中ch 首次出現的位置,當沒有在str 中找ch到返回NULL。

POJ1013稱硬幣【枚舉】