1. 程式人生 > >POJ2478 Farey Sequence(尤拉函式,打表)

POJ2478 Farey Sequence(尤拉函式,打表)

Farey Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13435 Accepted: 5272

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

題目大意:

法雷級數Fn(n >= 2)由一系列不能約分的分數a/b(0 < a < b  <= n 且gcd(a,b) =1)按遞增的順序排列組成,下面是法雷級數的前幾項: F2 = {1/2} F3 = {1/3,1/2,2/3} F4 = {1/4,1/3,1/2,2/3,3/4} F5 = {1/5,1/4,1/3,2/5,1/2,3/5,2/3,3/4,4/5}

解題思路:

一個法雷序列Fn中數的個數就是分別與2,3,4,5,....,n-1,n互素的數的個數和,繼而就是求從2到n連續的尤拉函式值的和,因為N的範圍是[2,1000000],可以直接用尤拉函式的遞推方法來求解,再打表預處理前n項和即可。

AC程式碼:

#include<iostream>
#include<cstdio>
using namespace std;

const int maxn = 1000001;
long long phi[maxn];

void dabiao()
{
	int i,j;
	for(i=1;i<=maxn;i++)
		phi[i] = i;
	for(i=2;i<=maxn;i+=2)
		phi[i] /= 2;
	for(i=3;i<=maxn;i+=2)
		if(phi[i] == i)
		{
			for(j=i;j<=maxn;j+=i)
			{
				phi[j] = phi[j] / i * (i-1);
			}
		}
	for(i=3;i<=1000001;i++)
	{
		phi[i] += phi[i-1]; 
	}
}

int main()
{
	int m;
	dabiao();
	while(scanf("%d",&m) != EOF && m)
	{
		printf("%lld\n",phi[m]);
	}
	return 0;
}