1. 程式人生 > >練習二1002

練習二1002

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description Now, here is a fuction:  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input 2 100 200
Sample Output -74.4291 -178.8534 題意: 在0到100之間,找到使 F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x 成立的最小值。 思路:

相當於y是個常數,求 F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)這個函式的最小值,令F' = 0,得出x,y的方程,用二分法解方程得x0(易證得x0>=0 && x0<=100),則F'(x0) = 0,由F'' 在[0-100]上恆大於0,所以F'在[0-100]上單增,所以F'(x)<0(x<x0),F'(x)>0(x>x0),所以F(x)在x=x0處取得最小值,所以本題主要就是二分求解方程的x0,然後直接帶入x0,y計算即可。

#include <cstdio>
#include <cmath>
#include <cstdlib>

const double eps = 1e-6;

double cal(double x){
	return 42*pow(x,6.0)+48*pow(x,5.0)+21*pow(x,2.0)+10*x;
}

double gao(double x,double y){
	return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-x*y;
}

int main(){
	int t;
	double low,high,y,x,res;

	scanf("%d",&t);
	while(t--){
		scanf("%lf",&y);
		low = 0.0;
		high = 100.0;
		while(high-low>eps){
			x = (low+high)/2;
			res = cal(x);
			if(res<y){
				low = x + 1e-8;
			}else{
				high = x - 1e-8;
			}
		}
		printf("%0.4lf\n",gao(x,y));
	}
	return 0;
}