1. 程式人生 > >HDU Strange fuction 1597

HDU Strange fuction 1597

find the nth digit

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 2
Problem Description 假設: S1 = 1 S2 = 12 S3 = 123 S4 = 1234 ......... S9 = 123456789 S10 = 1234567891 S11 = 12345678912 ............ S18 = 123456789123456789 .................. 現在我們把所有的串連線起來 S = 1121231234.......123456789123456789112345678912......... 那麼你能告訴我在S串中的第N個數字是多少嗎?
Input 輸入首先是一個數字K,代表有K次詢問。 接下來的K行每行有一個整數N(1 <= N < 2^31)。
Output 對於每個N,輸出S中第N個對應的數字.
Sample Input 6 1 2 3 4 5 10
Sample Output 1 1 2 1 2 4  思路:先找到在哪一個列 在找到是這一列的第幾個數字
#include <stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
long long a[100001];
int num[9]={9,1,2,3,4,5,6,7,8};
int main(int argc, char *argv[])
{
	int cnt=0,i;
	a[cnt]=0;
	for(i=1;i<70000;i++)
	{
		a[cnt]=a[cnt-1]+i;
		cnt++;
	}
	long long t;
	scanf("%lld",&t);
	while(t--)
	{
		long long n;
		scanf("%lld",&n);
		long long pos=lower_bound(a,a+70000,n)-a;
		long long c=n-a[pos-1];
		printf("%d\n",num[c%9]);
	}
	return 0;
}