YTU-OJ-長方柱類
阿新 • • 發佈:2019-01-27
Problem A: 長方柱類【C++ 類定義】
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 929 Solved: 681
[Submit][Status][Web Board]
Description
編寫基於物件的程式,求長方柱(Bulk)的體積。資料成員包括長(length)、寬(width)、高(heigth)、體積,要求用成員函式實現下面的功能:
(1)由鍵盤輸入長方柱的長、寬、高;
(2)計算長方柱的體積(volume)和表面積(areas);
(3)輸出這長方柱的體積和表面積。
(可以複製提示部分的程式碼開始你的程式設計)
Input
長方柱的長、寬、高
Output
長方柱的體積和表面積
Sample Input
2 3 4
Sample Output
24
52
HINT
class Bulk
{
public:
//此處宣告需要的成員函式
private:
double lengh;
double width;
double height;
};
//下面定義成員函式
//用main()函式測試,完成輸入輸出
int main()
{
Bulk b1;
b1.set_value();
cout<<b1.get_volume()<<endl;
cout<<b1.get_area()<<endl;
return 0;
}
<span style="font-size:14px;">/* *Copyright (c)2015,煙臺大學計算機與控制工程學院 *All rights reserved. *作 者:單昕昕 *完成日期:2015年5月16日 *版 本 號:v1.0 */ #include <iostream> using namespace std; class Bulk { public: Bulk(double l=1.0,double w=1.0,double h=1.0):length(l),width(w),height(h) {} double area(); double volume(); void get_value(); void output(); private: double length; double width; double height; }; void Bulk::get_value() { double l,w,h; cin>>l>>w>>h; length=l; width=w; height=h; } double Bulk::area() { return 2*(length*width+width*height+height*length); } double Bulk::volume() { return length*width*height; } void Bulk::output() { cout<<volume()<<'\n'<<area(); cout<<endl; } int main() { Bulk b; b.get_value(); b.output(); } </span>