並查集:HDU4496-D-City(倒用並查集)
D-City
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2448 Accepted Submission(s): 862
Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4
Sample Output
1
1
1
2
2
2
2
3
4
5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there’s only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
解題心得:
-題意就是給你一個圖,m個邊,從第一個邊開始每次取消一個,問你每次取消之後有多少個單獨的集合
-這個題看起來挺唬人的,其實就是將給出的點拿來從從後面開始合併就可以了。只要是不同源的相合並,那麼就必然少一個單獨的集合,思維不要僵化,換個方向想就可以了。
#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+10;
const int maxn2 = 1e4+10;
int n,m,father[maxn2];
stack <int> st;//因為是從後面開始合併,所以用棧來存放
struct node
{
int a,b;
}edge[maxn];
int find(int a)
{
if(father[a] == a)
return a;
else
return father[a] = find(father[a]);
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=0;i<=n;i++)
father[i] = i;
for(int i=0;i<m;i++)
scanf("%d%d",&edge[i].a,&edge[i].b);
int ans = n;
st.push(n);
for(int i=m-1;i>0;i--)//從後往前開始合併,注意第一條邊並沒有實際存在,因為在一開始就已經被破壞了
{
int fa = find(edge[i].a);
int fb = find(edge[i].b);
if(fa != fb)//不同源,集合必然少一個
{
father[fa] = fb;
ans--;
}
st.push(ans);
}
while(!st.empty())
{
printf("%d\n",st.top());
st.pop();
}
}
return 0;
}