1. 程式人生 > >由二叉樹的後序和中序求層次遍歷

由二叉樹的後序和中序求層次遍歷

PAT 1020

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2

題意:給出後序和中序,求出層次遍歷

#include <cstdio>
#include <cstring>
#include <queue>
#include <iostream>
using namespace std;
const int maxn=50;
struct node                     //節點 
{
	int date;
	node* ld;
	node* rd;
} ;
int pre[maxn],in[maxn],post[maxn];
int n;         //節點個數 
node* create(int postl,int postr,int inl,int inr)    //由後序和中序構建一顆樹 
{
	if(postl>postr)      
	return NULL;
	node* root=new node;              //建立一個新的節點,存放當前二叉樹的根節點         
	root->date =post[postr];          //新節點的資料域為當前根節點的值 
	int k;
	for(k=inl;k<=inr;k++)
	{
		if(in[k]==post[postr])
		break;
	}
	int numleft=k-inl;              //左子樹的節點個數 
	root->ld =create(postl,postl+numleft-1,inl,k-1);
	root->rd =create(postl+numleft,postr-1,k+1,inr);
	return root;
}
int num=0;                          //已經輸出的節點個數,便於空格輸出
void bfs(node* root)
{
	queue<node*> q;
	q.push(root);
	while(!q.empty()  )
	{
		node* now=q.front() ;
		q.pop() ;
		printf("%d",now->date );
		num++;
		if(num<n) printf(" ");	
		if(now->ld !=NULL) q.push(now->ld );
		if(now->rd !=NULL) q.push(now->rd );
		  
	 } 
}
int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)   //後序輸入 
	scanf("%d",&post[i]);
	for(int i=0;i<n;i++)  //中序輸入 
	scanf("%d",&in[i]);
	node* root=create(0,n-1,0,n-1);   
	bfs(root);           //層序輸出 
	return 0;
}