1. 程式人生 > >素數環(dfs)

素數環(dfs)

原題:

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27209    Accepted Submission(s): 12148


Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input n (0 < n < 20).

Output The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input 6 8
Sample Output Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
Source code: #include<stdio.h>
#include<math.h>
int visit[21]={0},num[21]={0},n;
int prime(int n)
{
int k;
for(k=2;k<=sqrt(n);k++)
if(n%k==0)
return 0;
return 1;
}
void dfs(int k)
{
int i;
if(k>n&&prime(num[n]+num[1]))
{
printf("%d",num[1]);
for(i=2;i<=n;i++)
printf(" %d",num[i]);
printf("\n");
}
else
{
for(i=2;i<=n;i++)
{
if(!visit[i]&&prime(num[k-1]+i))
{
num[k]=i;
visit[i]=1;
dfs(k+1);
visit[i]=0;
}
}
}
}


int main()
{
int cas=0;
while(scanf("%d",&n)!=EOF)
{
cas++;
printf("Case %d:\n",cas);
num[1]=1;
dfs(2);
printf("\n");
}
return 0;
}