ACM水題堆(一)T-switch game
阿新 • • 發佈:2019-02-01
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
InputEach test case contains only a number n ( 0< n<= 10^5) in a line.
OutputOutput the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).Sample Input
OutputOutput the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).Sample Input
1 5Sample Output
1 0 Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
這個題目主要是在題目意思的理解,輸入一個數i,執行到第I個步驟,每i個步驟的將十五個1中的第I和I的倍數位的數變為上一步操作相反的狀態,再輸出第I個狀態的數字,找規律就可以了
#include<iostream>
#include<cmath>using namespace std;int main()
{
int n;
while (scanf("%d", &n) != EOF)
{
//int con[16] = { 1 };
int i=sqrt(n);
if (pow(i, 2) == n)
{
cout << 1 << endl;
}
else
{
cout << 0 << endl;
}
}
return 0;
}