[kuangbin帶你飛]專題二 搜尋進階 E
The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.
For example, given “ACGT”,”ATGC”,”CGTT” and “CAGT”, you can make a sequence in the following way. It is the shortest but may be not the only one.
Input
The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.
Output
For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.
Sample Input
1
4
ACGT
ATGC
CGTT
CAGT
Sample Output
8
這道題是對退出DFS的判斷問題,首先要判斷一下最長的有多長,然後當
這個節點對所有的DNA都沒有貢獻時就退出,這裡用到了迭代加深搜尋,就是我每一次搜尋都指定一個最大搜索長度,如果大於這個搜尋長度就退出,然後再深入一層,防止無限次的加深搜尋
#include<bits/stdc++.h>
using namespace std;
#define bug cout<<"This is a BUG!"<<endl;
using LL=int64_t;
const int INF=0x3f3f3f3f;
int n,deep,ans=-1;
char s[10][10];
int size[10];
char cnt[5]={'A','T','C','G'};
void dfs(int num,int len[]) {
int sum=0;
if(ans!=-1||num>deep) return;
for(int i=0;i<n;i++) sum=max(sum,size[i]-len[i]);
if(num+sum>deep) return ;
if(sum==0) {ans=num;return ;}
for(int i=0;i<4;i++) {
int flag=0;
int tlen[10]={0};
for(int j=0;j<n;j++) {
if(s[j][len[j]]==cnt[i]) {
tlen[j]=len[j]+1;
flag++;
}
else tlen[j]=len[j];
}
if(flag>0)
dfs(num+1,tlen);
}
return ;
}
int main()
{
ios::sync_with_stdio(0);
cin.tie(0);
int T;
cin>>T;
for(int k=0;k<T;k++) {
ans=-1,deep=0;
cin>>n;
memset(s,0,sizeof(s));
for(int i=0;i<n;i++) {
cin>>s[i];
size[i]=strlen(s[i]);
deep=max(deep,size[i]);
}
int len[10]={0};
while(1) {
dfs(0,len);
if(ans!=-1) break;
deep++;
}
cout<<ans<<endl;
}
return 0;
}