1. 程式人生 > >最小生成樹 prime演算法 求權值最大的邊

最小生成樹 prime演算法 求權值最大的邊

Out of Hay

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43
演算法思想:最小生成樹 prime演算法  求最大權值的邊 
程式碼:
#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
const int maxn=1000000009;
int map[2010][2010];
int visited[2010];
int lowst[2010];
int n,m;
int prim()
{
    int pos,
minn,res=-1; memset(visited,0,sizeof(visited)); visited[1]=1; pos=1; for(int i=1;i<=n;i++) { if(pos!=i) lowst[i]=map[pos][i]; } for(int i=1;i<n;i++) { minn=maxn; for(int j=1;j<=n;j++) { if(!visited[j]&&minn>lowst[j]) { minn=lowst[j]; pos=j; } } if(res<minn) res=minn; visited[pos]=1; for(int j=1;j<=n;j++) { if(!visited[j]&&lowst[j]>map[pos][j]) lowst[j]=map[pos][j]; } } return res; } int main() { scanf("%d%d",&n,&m); for(int i=1;i<=n;i++) { for(int j=1;j<=n;j++) map[i][j]=maxn; } for(int i=0;i<m;i++) { int a,b,c; scanf("%d%d%d",&a,&b,&c); if(map[a][b]>c) map[a][b]=map[b][a]=c; } printf("%d\n",prim()); return 0; }