1. 程式人生 > >PAT1015. Reversible Primes (20)

PAT1015. Reversible Primes (20)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes

No

#include<iostream>
using namespace std;

bool isPrime(int n)
{
	if(n < 2)
		return false;
	if(n == 2)
		return true;
	if(n % 2 == 0)
		return false;
	for(int i = 3; i * i <= n; i++)
	{
		if(n % i == 0)
			return false;
	}
	return true;
}
int main()
{
	int n,d;
	scanf("%d",&n);
	while(n > 0)
	{
		scanf("%d",&d);
		if(isPrime(n))
		{
			int rn = 0;
			while(n != 0)
			{
				rn = rn * d + (n % d);
				n /= d;
			}
			if(isPrime(rn))
				printf("Yes\n");
			else
				printf("No\n");
		}
		else
			printf("No\n");
		scanf("%d",&n);
	}
	return 0;
}