1. 程式人生 > >UVA 540 Team Queue(queue的使用)

UVA 540 Team Queue(queue的使用)

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue. 

Input 

The input file will contain one or more test cases. Each test case begins with the number of teams t ( 1t1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements. 
Finally, a list of commands follows. There are three different kinds of commands: 
ENQUEUE x - enter element x into the team queue 
DEQUEUE - process the first element and remove it from the queue 
STOP - end of test case 
The input will be terminated by a value of 0 for t.

Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time. 

Output 

For each test case, first print a line saying “ Scenario #k”, where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 
Sample Input 

3 101 102 103 
3 201 202 203 
ENQUEUE 101 
ENQUEUE 201 
ENQUEUE 102 
ENQUEUE 202 
ENQUEUE 103 
ENQUEUE 203 
DEQUEUE 
DEQUEUE 
DEQUEUE 
DEQUEUE 
DEQUEUE 
DEQUEUE 
STOP 

5 259001 259002 259003 259004 259005 
6 260001 260002 260003 260004 260005 260006 
ENQUEUE 259001 
ENQUEUE 260001 
ENQUEUE 259002 
ENQUEUE 259003 
ENQUEUE 259004 
ENQUEUE 259005 
DEQUEUE 
DEQUEUE 
ENQUEUE 260002 
ENQUEUE 260003 
DEQUEUE 
DEQUEUE 
DEQUEUE 
DEQUEUE 
STOP 

Sample Output 
Scenario #1 
101 
102 
103 
201 
202 
203

Scenario #2 
259001 
259002 
259003 
259004 
259005 
260001

code(思路見註釋):

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <map>
#include <queue>

using namespace std;

int main()
{
    int t,cnt=1;
    while(cin>>t&&t)
    {
        map<int,int> IDgr;//成員p對映到他的隊伍i

        cout<<"Scenario #"<<cnt++<<endl;
        for(int i=1;i<=t;i++)
        {
            int n,p;
            cin>>n;
            while(n--)
            {
                cin>>p;
                IDgr[p]=i;
            }
        }
//佇列a存已在大隊伍中的各個支隊伍的序號,如{1,3,2}
//佇列陣列b存上面各個支隊伍中的成員,而且隊伍序號遞增,如{103,101,102},{201},{301,303}
        queue<int> a,b[1000];
        for(;;)
        {

            string cmd;
            cin>>cmd;
            if(cmd[0]=='S')
                break;
            else if(cmd[0]=='E')
            {
                int x;
                cin>>x;
                int id=IDgr[x];//成員x的隊伍id
                if(b[id].empty())//該成員不在大隊伍中
                    a.push(id);
                b[id].push(x);//新增新的隊伍序號
            }
            else if(cmd[0]=='D')
            {
                int z=a.front();//首支隊伍序號
                cout<<b[z].front()<<endl;//首支隊伍成員
                b[z].pop();

                if(b[z].empty())//如果首支隊伍沒有成員,則delete
                    a.pop();
            }
        }
        cout<<endl;
    }
    return 0;
}