1. 程式人生 > >水仙花數 (sdut oj)

水仙花數 (sdut oj)

水仙花數

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

春天是鮮花的季節,水仙花就是其中最迷人的代表,數學上有個水仙花數,是這樣定義的: 
“水仙花數”是指一個三位數,它的各位數字的立方和等於其本身,比如:153=13+53+33
現在要求輸出所有在m和n範圍內的水仙花數。

Input

輸入資料有多組,每組佔一行,包括兩個整數m和n(100<=m<=n<=999)。

Output

對於每個測試例項,要求輸出所有在給定範圍內的水仙花數,就是說,輸出的水仙花數必須大於等於m,並且小於等於n,如果有多個,則要求從小到大排列在一行內輸出,之間用一個空格隔開;
如果給定的範圍內不存在水仙花數,則輸出no;
每個測試例項的輸出佔一行。

Example Input

100 120
300 380

Example Output

no
370 371

Hint

Author

HDOJ






參考程式碼

#include<stdio.h>
int main()
{
    int m,n;
    int i;
    int sum;
    int a1,a2,a3;
    int flag;
    int temp;
    while(~scanf("%d%d",&m,&n))
    {
        flag = 0;
        temp = 0;
        for(i = m; i <= n; i++)
        {
            a1 = i % 10;
            a2 = i / 10 % 10;
            a3 = i / 100;
            sum= a1 * a1 * a1 + a2 * a2 * a2 + a3 * a3 * a3;
            if(sum == i)
            {
                temp++;
                if(temp == 1)
                    printf("%d",i);
                else
                    printf(" %d",i);
            }
            else
                flag++;
        }
        if(flag == (n - m) + 1)
            printf("no");
        printf("\n");
    }
    return 0;
}