1. 程式人生 > >More Is better-並查集

More Is better-並查集

problem election gin one dia second complex ace href

原題鏈接:https://vjudge.net/problem/11137/origin

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang‘s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
Sample Output
4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

題解:題目的意思就是找出數量最多的那個集合,並查集也就最後掃一下se就可以了(感覺樹狀數組也能做),這裏有個特判點就是當n為0的時候是輸出1的(這樣最大的集合人數為1).差點1a了.

#include <bits/stdc++.h>
const int N=1e7+5;
using namespace std;
int se[N];
int ma[N];
int fd(int a){
    int x=a;
    while(se[x]!=x){
        x=se[x];
        for(int i=a,j;i!=x;i=j){
            j=se[i];
            se[i]=x;
        }
    }
    return x;
}
void join(int a,int b){
    int fa=fd(a);
    int fb=fd(b);
    se[fb]=fa;
}
int main()
{
    int n;
    while(~scanf("%d",&n)){
        if(n==0){
            printf("1\n");
            continue;
        }
        for(int i=1;i<=2*n;i++) se[i]=i;
        for(int i=1;i<=n;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            join(a,b);
        }
        memset(ma,0,sizeof(ma));
        for(int i=1;i<=2*n;i++) ma[fd(i)]++;
        int ans=0;
        for(int i=1;i<=2*n;i++) ans=max(ans,ma[i]);
        printf("%d\n",ans);
    }

    //cout << "Hello world!" << endl;
    return 0;
}

More Is better-並查集