1. 程式人生 > >YTU OJ-1329: 手機尾號評分

YTU OJ-1329: 手機尾號評分

1329: 手機尾號評分

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 204  Solved: 139
[Submit][Status][Web Board]

Description


    30年的改革開放,給中國帶來了翻天覆地的變化。2011全年中國手機產量約為11.72億部。手機已經成為百姓的基本日用品!

    給手機選個好聽又好記的號碼可能是許多人的心願。但號源有限,只能輔以有償選號的方法了。

    這個程式的目的就是:根據給定的手機尾號(4位),按照一定的規則來打分。其規則如下:

    1. 如果出現連號,不管升序還是降序,都加5分。例如:5678,4321都滿足加分標準。

    2. 前三個數字相同,或後三個數字相同,都加3分。例如:4888,6665,7777都滿足加分的標準。注意:7777因為滿足這條標準兩次,所以這條規則給它加了6分。

    3. 符合AABB或者ABAB模式的加1分。例如:2255,3939,7777都符合這個模式,所以都被加分。注意:7777因為滿足這條標準兩次,所以這條標準給它加了2分。

    4. 含有:6,8,9中任何一個數字,每出現一次加1分。例如4326,6875,9918都符合加分標準。其中,6875被加2分;9918被加3分。

    尾號最終得分就是每條標準的加分總和!

Input

第一行是一個整數n(<100),表示下邊有多少輸入行,接下來是n行4位一組的資料,就是等待計算加分的手機尾號。

Output

n行整數。

Sample Input

14
3045
0211
2345
6543
7777
8888
7878
7788
6688
2424
2244
9918
6789
8866

Sample Output

0
0
5
6
8
12
3
3
5
1
1
3
8
5
import java.util.*;
public class 手機尾號評分{
	//連號
	public static boolean lh(int[][] a,int t) {
		if(a[t][1]==(a[t][0]+1)&&a[t][2]==(a[t][1]+1)&&a[t][3]==(a[t][2]+1)||
				a[t][1]==(a[t][0]-1)&&a[t][2]==(a[t][1]-1)&&a[t][3]==(a[t][2]-1))
			return true;
		return false;
	}
	//前三個或後三個數字相同
	public static boolean st(int[][] a,int t) {
		if(a[t][0]==a[t][1]&&a[t][1]==a[t][2]||
				a[t][1]==a[t][2]&&a[t][2]==a[t][3])
			return true;
		return false;
	}
	//前兩個和後兩個分別相同
	public static boolean st1(int[][] a,int t) {
		if(a[t][0]==a[t][1]&&a[t][2]==a[t][3]||a[t][0]==a[t][2]&&a[t][1]==a[t][3])
			return true;
		return false;
	}
	//出現6,8,9
	public static int p(int[][] a,int t) {
		int count=0;
		for(int i=0;i<4;i++) {
			if(a[t][i]==6||a[t][i]==8||a[t][i]==9)
				count++;
		}
		return count;
	}
	//四個數字相同
	public static boolean st3(int[][] a,int t) {
		if(a[t][0]==a[t][1]&&a[t][1]==a[t][2]&&a[t][2]==a[t][3])
			return true;
		return false;
	}
	public static void f(int[][] a,int n) {
		int t=0,sum;
		while(t<n) {
			sum=0;
			sum+=p(a,t);
			if(lh(a,t))
				sum+=5;
			if(st3(a,t))
				sum+=8;
			else if(!st3(a,t)){
				
				if(st(a,t)) {
					sum+=3;
				}
				if(st1(a,t)) {
					sum+=1;
				}
			}
			System.out.println(sum);
			t++;
		}
	}
	public static void main(String[] args) {
		Scanner in=new Scanner(System.in);
		int n=in.nextInt();
		int[][] a=new int[n][4];
		String s=" ";
		s=in.nextLine();
		for(int i=0;i<n;i++) {
			s=in.nextLine();
			for(int j=0;j<s.length();j++) {
				a[i][j]=(int)(s.charAt(j)-48);
			}
		}
		f(a,n);
	}

}