1. 程式人生 > >POJ2253:Frogger(改造Dijkstra)

POJ2253:Frogger(改造Dijkstra)

iostream minimax node wim 鏈接 cep seve lan inpu

Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 64864 Accepted: 20127

題目鏈接:http://poj.org/problem?id=2253

Description:

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists‘ sunscreen, he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona‘s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog‘s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy‘s stone, Fiona‘s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy‘s and Fiona‘s stone.

Input:

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy‘s stone, stone #2 is Fiona‘s stone, the other n-2 stones are unoccupied. There‘s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output:

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input:

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output:

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

題意:

在一個二維平面內,給出一些點的坐標,問從起點到終點距離最大值最小為多少。

題解:

思路和另外一道題有類似,可以看看那道題的題解:https://www.cnblogs.com/heyuhhh/p/10352107.html

都是利用貪心的思想去做,類比一下,想想就出來了。

我就直接給代碼吧~

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <cmath>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N = 205;
int n;
int x[N],y[N],head[N],vis[N];
int tot;
double d[N];
double dis(int a,int b){
    return sqrt((double)(x[a]-x[b])*(x[a]-x[b])+(double)(y[a]-y[b])*(y[a]-y[b]));
}
struct Edge{
    int u,v,next;
    double w;
}e[N*N<<1];
struct node{
    int u;
    double d;
    bool operator < (const node &A)const{
        return d>A.d;
    }
};
void adde(int u,int v,double w){
    e[tot].v=v;e[tot].next=head[u];e[tot].w=w;head[u]=tot++;
}
void Dijkstra(int s){
    priority_queue <node> q;
    for(int i=1;i<=n;i++) d[i]=INF;
    memset(vis,0,sizeof(vis));
    node now;d[s]=0;
    now.d=0;now.u=s;
    q.push(now);
    while(!q.empty()){
        node cur = q.top();q.pop();
        int u=cur.u;
        if(vis[u]) continue ;
        vis[u]=1;
        for(int i=head[u];i!=-1;i=e[i].next){
            int v=e[i].v;
            if(d[v]>max(d[u],e[i].w)){
                d[v]=max(d[u],e[i].w);
                now.d=d[v];now.u=v;
                q.push(now);
            }
        }
    }
}
int main(){
    int cnt =0;
    while(scanf("%d",&n)!=EOF){
        if(n==0) break ;
        cnt++;
        memset(head,-1,sizeof(head));tot=0;
        for(int i=1;i<=n;i++) scanf("%d%d",&x[i],&y[i]);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                if(i==j) continue ;
                adde(i,j,dis(i,j));
            }
        }
        Dijkstra(1);
        printf("Scenario #%d\n",cnt);
        printf("Frog Distance = %.3f\n",d[2]);
        printf("\n");
    }
    return 0;
}

POJ2253:Frogger(改造Dijkstra)