1031. Hello World for U (20)
PAT
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:
h d
e l
l r
lowoThat is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.
Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:
For each test case, print the input string in the shape of U as specified in the description.
Sample Input:helloworld!
Sample Output:
h !
e d
l l
lowor
題目大意:一串字串,按U型輸出,其中n1行,n2列,n3==n1;
條件:n1<=n2&&n1+n2+n3-2==字串長n,求取最大n1
程式碼
#include<cstdio>
#include<cstring>
int main()
{
char a[100];
while(scanf("%s",a)!=EOF){
int n = strlen(a);
int n1 = 0, n2 = 0;
for(int i = 0; i < n; i++){//求出n1的最大值
n1 = i;
n2 = n+2-2*n1;
if(n2 < n1) break;
}
n1--;
n2 = n+2-2*n1;
for(int i = 0; i < n1-1; i++){
printf("%c",a[i]);
for(int j = 0;j< n2-2;j++)
printf(" ");
printf("%c\n",a[n-1-i]);
}
for(int i = n1-1; i < n1-1+n2; i++)
printf("%c",a[i]);
printf("\n");
}
}