1. 程式人生 > >POJ 2142 The Balance [不定方程和最小的正整數解]【數論】

POJ 2142 The Balance [不定方程和最小的正整數解]【數論】

——————————————–.

The Balance
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 5998 Accepted: 2610
Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights.
You are asked to help her by calculating how many weights are required.
這裡寫圖片描述

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider “no solution” cases.
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.
Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions.
You can measure dmg using x many amg weights and y many bmg weights.
The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition.
The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.
Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0
Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1
Source

————————–.
題目大意 :
就是有一個天平 現在你要稱N質量的物體
你只有a,b兩種質量的砝碼若干
問你最少需要每種砝碼多少個才能稱出N質量的物體
(要求在個數相同的時候選取砝碼質量和最少的組合)

解題思路:
這道題目其實很簡單 打眼一瞅就知道是一個擴充套件歐幾里得

但是對於怎麼輸出最小的解得組合 這點就不太容易了

其實呢也不難 稍加分析就能得到結果了
首先呢
運用擴充套件歐幾里得能夠求出x,y的任意一組解
這樣的話 假如求x或y的最小正整數解釋非常容易的
只要x=(x%a+a)%a y=(x%b+b)%b這樣就行了
然後想 要求出|x|+|y|的最小值怎麼辦呢
其實無非是兩種
一種是在x為最小正整數解的時候
另一種是在y為最小正整數解的時候
證明略(取數是稍微想一想就知道了)

知道這個就好了

最後把兩種的結果一比較 就能得出符合題意的解了

附本題程式碼
——————.

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
typedef long long int LL ;
#define INF 0x3f3f3f3f
#define pb push_back
#define abs(a) (a)>0?(a):-(a)
#define lalal puts("*******");
/*************************************/
LL exgcd(LL a,LL b,LL &x,LL &y)
{
    if(!b)
    {
        x=1,y=0;
        return a;
    }
    else
    {
        LL r = exgcd(b,a%b,x,y);
        LL t = x;
        x = y;
        y = t-(a/b)*y;
        return r;
    }
}

int main()
{
    int a,b,d;
    while(~scanf("%d%d%d",&a,&b,&d)&&(a||b||d))
    {

        LL x,y,vx,vy;

        LL r = exgcd(a,b,x,y);  //本題讓求最小解
        a/=r,b/=r,d/=r;

        exgcd(a,b,x,y);

        /**********①令y是最小正整數解**********/
        vy = y*d;
        vy = (vy % a + a) % a;
        vx = (d-b*vy) / a;
        vx = abs(vx);
        /**********②令x是最小正整數解**********/
        x *= d;
        x = (x % b + b) % b;
        y = (d-a*x) / b;         //同理
        y = abs(y);
        /**********③使得和最小**********/
        if(x+y<vx+vy)    vx=x,vy=y;


        printf("%I64d %I64d\n",abs(vx),abs(vy));
    }
    return 0;
}