poj3169Layout【差分約束】
阿新 • • 發佈:2019-02-08
Language:
Layout
Description Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints. Input Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart. Output Sample Input 4 2 1 1 3 10 2 4 20 2 3 3 Sample Output 27 Hint Explanation of the sample:There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27. Source |
題意:編號為1到n的牛排隊有些牛是比較友好的需要使他們的相隔的最大距離不能大於某個值還有一些牛需要使他們的最小距離大於某個值求1號牛到n號牛之間能夠相隔的最大距離
設:s[i]為第i牛所在的座標所以有約束條件s[b]-s[a]<=mls[b]-s[a]>=md;s[i+1]-s[]i]>=0;
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=10010;
struct Node{
int from,to,value;
int next;
}A[maxn<<2];
int cnt[maxn];
int dist[maxn];
bool vis[maxn];
int head[maxn],node;
void init(){
node=0;
memset(cnt,0,sizeof(cnt));
memset(vis,false,sizeof(vis));
memset(head,-1,sizeof(head));
memset(dist,0x3f,sizeof(dist));
}
void add(int u,int v,int c){
A[node].from=u;
A[node].to=v;
A[node].value=c;
A[node].next=head[u];
head[u]=node++;
}
int spfa(int n){
int i,j,k,u=1;
queue<int>Q;
dist[u]=0;vis[u]=true;
Q.push(u);cnt[u]=1;
while(!Q.empty()){
u=Q.front();Q.pop();
vis[u]=false;
for(k=head[u];k!=-1;k=A[k].next){
int v=A[k].to;
if(dist[v]>dist[u]+A[k].value){
dist[v]=dist[u]+A[k].value;
if(!vis[v]){
cnt[v]++;
if(cnt[v]>n)return -1;
vis[v]=true;
Q.push(v);
}
}
}
}
return dist[n];
}
int main()
{
int t,i,j,k,ml,md,n;
while(scanf("%d%d%d",&n,&ml,&md)!=EOF){
int a,b,c;init();
for(i=0;i<ml;++i){
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
}
for(i=0;i<md;++i){
scanf("%d%d%d",&a,&b,&c);
add(b,a,-c);
}
for(i=1;i<=n;++i){
add(i+1,i,0);
}
int ans=spfa(n);
if(ans==inf){
printf("%d\n",-2);
}
else if(ans==-1){
printf("%d\n",-1);
}
else {
printf("%d\n",ans);
}
}
return 0;
}