1134 Vertex Cover(25 分)
A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:
Nv v[1] v[2]⋯v[Nv]
where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.
Output Specification:
For each query, print in a line Yes
No
if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No
思路:
n個頂點和m條邊的圖,分別給出m條邊的兩端頂點,然後對其進行k次查詢,每次查詢輸入一個頂點集合,要求判斷這個頂點集合是否能完成頂點覆蓋,即圖中的每一條邊都至少有一個頂點在這個集合中。
C++:
#include "iostream"
#include "vector"
using namespace std;
vector<vector<int> > e;
int main(){
int n,m,k;
scanf("%d %d",&n,&m);
e.resize(n);
for (int i=0;i<m;i++)
{
int a,b;
scanf("%d %d",&a,&b);
e[a].push_back(i);
e[b].push_back(i);
}
int N;
scanf("%d",&k);
for (int i=0;i<k;i++)
{
scanf("%d",&N);
int flag=0,num;
vector<int> hash(m, 0);
for (int j=0;j<N;j++){
scanf("%d",&num);
for (int t = 0; t < e[num].size(); t++)
hash[e[num][t]] = 1;
}
for (int j = 0; j < m; j++) {
if (hash[j] == 0) {
printf("No\n");
flag = 1;
break;
}
}
if (flag == 0) printf("Yes\n");
}
return 0;
}