1. 程式人生 > >(poj3107Godfather,樹形dp,next陣列)樹的重心

(poj3107Godfather,樹形dp,next陣列)樹的重心

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6
Sample Output

2 3
Source

Northeastern Europe 2005, Northern Subregion
題目大意:給定一顆有n個節點的樹,求出這棵樹的所有重心,並按編號從大到小輸出。
先給出樹的重心的定義:一棵樹的重心是指刪除這個節點之後使樹分成幾個部分,使得這幾個部分中節點個數的最大值最小。
其實求法非常簡單
用son[i]表示節點i的子節點有多少個。
blance表示以節點i為父親的子樹中節點個數的最大值。
那麼刪除節點i之後形成的幾個部分中節點個數的最大值為
max(blance,n-son[i]-1);
然後我們dfs一遍就好了。
注意用vector會超時。需要使用next陣列。。
程式碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int N=50010;
const int inf=2100000000LL;
struct use{
    int st,en;
}b[1000001];
int son[N],n,ans[N],minn,next[5000001]={0},point[100001]={0},tot;
bool f[N];
void add(int x,int y)
{
    tot++;next[tot]=point[x];point[x]=tot;
    b[tot].st=x;b[tot].en=y;
}
void dfs(int x)
{
    int i,j,u,balance=0;
    son[x]=0;
    f[x]=false;
    for(i=point[x];i;i=next[i]){
        u=b[i].en;
        if(!f[u]) continue;
        dfs(u);
        son[x]+=son[u]+1;
        balance=max(balance,son[u]+1);
    }
    balance=max(balance,n-son[x]-1);
    if(balance<minn){
        minn=balance;
        ans[0]=1;
        ans[1]=x;
    }
    else if(balance==minn){
        ans[0]+=1;
        ans[ans[0]]=x;
    }
}
int main()
{
    int i,j,x,y;
    scanf("%d",&n);
    minn=inf;
    memset(f,1,sizeof(f));
    for(i=1;i<n;++i){
        scanf("%d%d",&x,&y);
        add(x,y);
        add(y,x);       
    }
    dfs(1);
    sort(ans+1,ans+ans[0]+1);
    for(i=1;i<=ans[0];++i) 
      printf("%d ",ans[i]);
    printf("\n");
}