1. 程式人生 > >POJ 2531 Network Saboteur 暴力

POJ 2531 Network Saboteur 暴力

Network Saboteur
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11392 Accepted: 5513

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

Source

//比賽完 心情是相當不爽的 這道題看了無數次看不懂

//英語是硬傷啊

//題意是把n分成兩堆 要求一邊的每個點到另一邊所有點的距離總和最大

//比如 樣例 分成 (1,3)  和(2) 

//硬是沒看懂 各種猜測

// 沒意思路 爆搜唄 每個點都有兩種情況 DFS (2^20);

#include<stdio.h>
#include<string.h>
int l,n,msum;
int vis[30];
int ap[30][30];
void  dfs(int k)
{
    int i,j,sum;
    if(k==n)
    {
        sum=0;
        for(i=1; i<=n; i++)
        {
            if(vis[i]==0) continue;
            for(j=1; j<=n; j++)
            {
                if(vis[j]==0)
                    sum+=ap[i][j];
            }
        }
        if(msum<sum)
            msum=sum;
        return ;
    }
    vis[k]=1;
    dfs(k+1);
    vis[k]=0;
    dfs(k+1);
}

int main()
{
    int i,j;
    scanf("%d",&n);
    msum=0;
    for(i=1; i<=n; i++)
        for(j=1; j<=n; j++)
        {
            scanf("%d",&ap[i][j]);
        }
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    dfs(1);
    printf("%d\n",msum);
    return 0;
}