遞推——爬樓梯
阿新 • • 發佈:2019-02-11
Problem Description
小明是個非常無聊的人,他每天都會思考一些奇怪的問題,比如爬樓梯的時候,他就會想,如果每次可以上一級臺階或者兩級臺階,那麼上 n 級臺階一共有多少種方案?
Input
輸入包含多組測試資料,對於每組測試資料:
輸入只有一行為一個正整數 n(1 ≤ n ≤ 50)。
Output
對於每組測試資料,輸出符合條件的方案數。
注意:64-bit 整型請使用 long long 來定義,並且使用 %lld 或 cin、cout 來輸入輸出,請不要使用 __int64 和 %I64d。
Example Input
2
4
Example Output
2
5
Hint
Author
#include <stdio.h>
int main()
{
int n, i;
while(scanf("%d", &n) != EOF)
{
long long f[n+1];
f[1] = 1, f[2] = 2;
for(i = 3; i <= n; i++)
{
f[i] = f[i-1] + f[i-2];
}
printf("%lld\n", f[n]);
}
return 0;
}