1. 程式人生 > >PAT題目:1131. Subway Map (30)

PAT題目:1131. Subway Map (30)

PAT題目:1131. Subway Map (30)

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.


Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (< =100), the number of subway lines. Then N lines follow, with the i-th (i = 1, ..., N) line describes the i-th subway line in the format:

M S[1] S[2] ... S[M]

where M (<= 100) is the number of stops, and S[i]'s (i = 1, ... M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order -- that is, the train travels between S[i] and S[i+1] (i = 1, ..., M-1) without any stop.

Note: It is possible to have loops, but not self-loop (no train starts from S and stops at S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called "transfer stations"), no station can be the conjunction of more than 5 lines.

After the description of the subway, another positive integer K (<= 10) is given. Then K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.

The following figure shows the sample map.


Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.

Output Specification:

For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:

Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
......

where Xi's are the line numbers and Si's are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.

If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.

Sample Input:
4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001
Sample Output:
2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.

解析:這道題我一開始想複雜了,其實是一道深搜的題目。開一個10000*10000的二維陣列,儲存每兩個station之間屬於哪條線路。注意最後應該是一個無向圖。深搜到達目的地時,判斷此時的路徑長短和之前儲存的結果的大小關係,如果路徑長短等於上一個結果,則比較換乘數目。至於換乘數目如何得到,我是定義一個linenum記錄當前在哪條線,深搜找到下一個station時,若從當前station到下一個station的路段不在當前線路,則讓linenum變化。上程式碼:

#include<bits/stdc++.h>
#include<cstdio>
#define MAX 10000
int line[MAX][MAX];
bool visit[MAX];
int n,q,k,from,to;
int mindist = 1<<30;
int result[MAX];
int transfer = 1<<30;
int linenum = 0;
int temp[MAX];
int pointer = 0;
using namespace std;
void init(){
    mindist = 1<<30;
    pointer = 0;
    transfer= 1<<30;
    memset(visit,sizeof(visit),false);
}
void collres(){
    for(int i = 0 ; i < pointer; i++){
        result[i] = temp[i];
    }
    mindist = pointer - 1;
    //cout<<mindist<<endl;
}
void dfs(int f,int dist,int trans){
    if(dist > mindist)
        return;
    if(f == to){
        if(dist == mindist && trans >= transfer) return;
        temp[pointer++] = f,collres();
        pointer--;
        transfer = trans;
        return ;
    }
    int current = linenum;
    visit[f] = true;
    temp[pointer++] = f;
    for(int i = 0; i < MAX; i++){
        if(line[f][i] && !visit[i]){
            if(line[f][i] != linenum)
                linenum = line[f][i],dfs(i,dist + 1,trans + 1),linenum = current;
            else
                dfs(i,dist + 1,trans);
        }
    }
    visit[f] = false;
    pointer --;
}
int main(){
    cin>>n;
    for(int i = 1; i <= n; i++){
        cin>>k;
        cin>>from;
        for(int j = 1; j < k; j++){
            cin>>to;
            line[from][to] = i;
            line[to][from] = i;
            from = to;
        }
    }
    cin>>q;
    while(q--){
        init();
        cin>>from>>to;
        if(from == to){
            cout<<0<<endl;
            continue;
        }
        dfs(from,0,0);
        cout<<mindist<<endl;
        int last = line[result[0]][result[1]];
        printf("Take Line#%d from %04d ",last,result[0]);
        for(int i = 2; i < mindist  + 1; i++){
            if(line[result[i - 1]][result[i]] != last){
                printf("to %04d.\n",result[i - 1]);
                last = line[result[i - 1]][result[i]];
                printf("Take Line#%d from %04d ",last,result[i - 1]);
            }
        }
        printf("to %04d.\n",result[mindist]);
    }
}