1. 程式人生 > >hdu 1258 Sum It Up 搜尋

hdu 1258 Sum It Up 搜尋

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general. 
InputThe input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions. 
OutputFor each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice. 
Sample Input
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0
Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25

50+50+50+50+50+25+25+25+25+25+25

題意:輸入n,m,和m個數,求m個數的其中一些或者全部相加是否可以等於n,如果可以,從大到小輸

出這些數

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m,a[15],num[15],b[15],flag;
bool cmp(int x,int y)
{
    return x>y;
}
void dfs(int x,int y,int sum)
{
    if(num[m]-num[x-1]<sum) //把後面的數全部加上還是比要求的數小,則不可能
        return;
    if(sum==0) //找到結果輸出
    {
        flag=1;
        printf("%d",b[1]);
        for(int i=2; i<y; i++)
            printf("+%d",b[i]);
        printf("\n");
        return;
    }
    for(int i=x; i<=m; i++)
    {
        if(a[i]<=sum) 
        {
            b[y]=a[i];
            dfs(i+1,y+1,sum-a[i]);
            while(i+1<=m&&a[i]==a[i+1])//同一個位置如果填相同的數勢必會重複
                i++;
        }

    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        flag=0;
        memset(b,0,sizeof(b));
        num[0]=0;
        for(int i=1; i<=m; i++)
            scanf("%d",&a[i]);
        sort(a+1,a+1+m,cmp); //從大到小排序
        for(int i=1; i<=m; i++)
            num[i]=num[i-1]+a[i];//每一個數及它前面數的和
        printf("Sums of %d:\n",n);
        if(num[m]<n) //所有的數相加比n還小,則不可能
        { 
            printf("NONE\n");
            continue;
        }
        dfs(1,1,n);
        if(flag==0)
            printf("NONE\n");
    }
    return 0;
}