acm 2 1001 二分法
1.1001
2.
Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input 2<br>100<br>-4<br>
Sample Output 1.6152<br>No solution!<br> 3.基本題意,對於題中方程,輸入已知的y值,計算出x的值
4.本題中方程以確定,y值是給定的值,求x,並且對x設定了範圍限制,是基本的二分思想,逐步縮小範圍,直到解出或無解
5.
#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
using namespace std;
double f(double x)
{
double l;
l=8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
return l;
}
int main()
{
double n,i,k,z,l,e;
double t,t1,t2;
double x,y;
cin>>n;
while(n--)
{
cin>>y;
if(f(0)>y||f(100)<y)
{
cout<<"No solution!"<<endl;
continue;
}
else
{
t1=0;
t2=100;
while(t2-t1>0.00000001)
{
t=(t2+t1)/2;
k=f(t);
if(k>y) t2=t;
else t1=t;
}
cout<<fixed<<setprecision(4)<<t<<endl;
}
}
return 0;
}