acm 2 1002 二分查詢
1.1002
2.
Problem Description Now, here is a fuction:<br> F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 《= x 《=100) Can you find the minimum value when x is between 0 and 100.Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input 2<br>100<br>200
Sample Output -74.4291<br>-178.8534
Author Redow
3.基本題意,對於給定的方程,找出確定範圍內的最小值x
4.F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x ,分析方程,對於x的部分求導,導數小於0遞減,倒數大於0遞增,找到導數中的拐點,拐點處函式值最小,使用二分法查詢
5.
#include<iostream>
#include<vector>
#include<algorithm>
#include<numeric>
#include<string.h>
#include<sstream>
#include<string>
#include<map>
#include<queue>
#include<iomanip>
using namespace std;
double f(double x)
{
double l;
l=42*x*x*x*x*x*x+48*x*x*x*x*x+21*x*x+10*x;
return l;
}
double f1(double x)
{
double l;
l=6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x;
return l;
}
int main()
{
double n,i,k,z,l,e;
double t,t1,t2;
double x,y;
cin>>n;
while(n--)
{
cin>>y;
t1=0;
t2=100;
while(t2-t1>0.0000001)
{
t=(t2+t1)/2;
k=f(t)-y;
if(k>0) t2=t;
else t1=t;
}
z=f1(t)-y*t;
cout<<fixed<<setprecision(4)<<z<<endl;
}
return 0;
}