1. 程式人生 > >poj2528——Mayor's posters(離散化+區間覆蓋)

poj2528——Mayor's posters(離散化+區間覆蓋)

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.
Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,… , ri.
Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.
這裡寫圖片描述
Sample Input

1
5
1 4
2 6
8 10
3 4
7 10
Sample Output

4

給出一些區間,要按順序將這些區間貼上海報,因此有些海報會被覆蓋,求最終能看到多少種海報,只能看到一部分的也算。
可以用線段樹來解決,貼著海報的區間用一個獨一無二的值覆蓋,最後查詢整個區間有多少種覆蓋的值就行。但問題是題目的值很大,直接按照給的區間去覆蓋肯定會超時,因此要離散化,只需要知道端點的值就夠了,將這些端點儲存下來,照它們的相對位置去覆蓋,比如覆蓋1~10,1000~2000和覆蓋1~2,3~4就沒區別。
但還有個問題就是這種離散化之後會丟失中間的資料,假如有三張海報,第一張很長,剩下兩張正好覆蓋在海報的兩端,中間的部分會露出來,這樣的情況一般的離散化之後只會算出兩張,因為中間沒有資料,後面的兩張擠到一起去了,神奇的是這樣poj也能過,這明顯是不對的。所以要給每個區間都再加一個右端點+1的數,防止這種情況。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#include <ctime>
#define INF 0x3f3f3f3f
#define MAXN 100005
#define Mod 1000000007
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int col[MAXN<<3],hsh[MAXN<<3],li[MAXN],ri[MAXN];
int n,vis[MAXN<<3],ans;
void pushdown(int rt)
{
    if(col[rt]!=-1)
    {
        col[rt<<1]=col[rt<<1|1]=col[rt];
        col[rt]=-1;
    }
}
int binsearch(int num,int n,int a[])
{
    int low=0,high=n-1,mid;
    while(low<=high)
    {
        mid=(low+high)>>1;
        if(a[mid]==num)
            return mid;
        else if(a[mid]<num)
            low=mid+1;
        else
            high=mid-1;
    }
    return -1;
}
void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        col[rt]=c;
        return;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(L<=m)
        update(L,R,c,lson);
    if(R>m)
        update(L,R,c,rson);
}
void query(int l,int r,int rt)
{
    if(col[rt]!=-1)
    {
        if(!vis[col[rt]])
            ans++;
        vis[col[rt]]=1;
        return;
    }
    if(l==r)
        return;
    int m=(l+r)>>1;
    query(lson);
    query(rson);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(col,-1,sizeof(col));
        int n,nn=0;
        scanf("%d",&n);
        for(int i=0; i<n; ++i)
        {
            scanf("%d%d",&li[i],&ri[i]);
            hsh[nn++]=li[i];
            hsh[nn++]=ri[i];
        }
        sort(hsh,hsh+nn);
        int m=1;
        for(int i=1; i<nn; ++i)
        {
            if(hsh[i]!=hsh[i-1])
                hsh[m++]=hsh[i];
        }
        for(int i=m-1;i>0;--i)
        {
            if(hsh[i]!=hsh[i-1]+1)
                hsh[m++]=hsh[i-1]+1;
        }
        sort(hsh,hsh+m);
        for(int i=0; i<n; ++i)
        {
            int l=binsearch(li[i],m,hsh);
            int r=binsearch(ri[i],m,hsh);
            update(l,r,i,0,m-1,1);
        }
        memset(vis,0,sizeof(vis));
        ans=0;
        query(0,m-1,1);
        printf("%d\n",ans);
    }
    return 0;
}