1. 程式人生 > >【杭電oj】1280

【杭電oj】1280

前m大的數

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15329    Accepted Submission(s): 5221


Problem Description 還記得Gardon給小希佈置的那個作業麼?(上次比賽的1005)其實小希已經找回了原來的那張數表,現在她想確認一下她的答案是否正確,但是整個的答案是很龐大的表,小希只想讓你把答案中最大的M個數告訴她就可以了。 
給定一個包含N(N<=3000)個正整數的序列,每個數不超過5000,對它們兩兩相加得到的N*(N-1)/2個和,求出其中前M大的數(M<=1000)並按從大到小的順序排列。
Input 輸入可能包含多組資料,其中每組資料包括兩行: 
第一行兩個數N和M, 
第二行N個數,表示該序列。


Output 對於輸入的每組資料,輸出M個數,表示結果。輸出應當按照從大到小的順序排列。
Sample Input 4 4 1 2 3 4 4 5 5 3 6 4
Sample Output 7 6 5 5 11 10 9 9 8
Author Gardon
Source

也許是我沒抓到關鍵的知識點吧,反正就是都列舉出來,排序一下,然後輸出就完了,感覺很水就過了。

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[3000*1500+50];
bool cmp(int a,int b)
{
	return a>b;
}

int main()
{
	int num[3111];
	int n,m;
	while (~scanf ("%d %d",&n,&m))
	{
		for (int i=0;i<n;i++)
			scanf ("%d",&num[i]);
		int t = 0;
		for (int i=0;i<n-1;i++)
		{
			for (int j=i+1;j<n;j++)
			{
				a[t++] = num[i]+num[j];
			}
		}
		sort (a,a+t,cmp);
		for (int i=0;i<m-1;i++)
			printf ("%d ",a[i]);
		printf ("%d\n",a[m-1]);
	}
	return 0;
}