1. 程式人生 > >Pat(Advanced Level)Practice--1053(Path of Equal Weight)

Pat(Advanced Level)Practice--1053(Path of Equal Weight)

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti

. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than

 sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
AC程式碼: 對其進行深度優先搜尋即可,注意輸出的順序,所以我們這裡先對權重較大的節點進行搜尋,這樣就免去了排序的步驟了。
#include<cstdio>
#include<vector>
#include<algorithm>
#define MAX 105

using namespace std;

vector<int> adjoin[MAX];
vector<int> path;
int visited[MAX],weight[MAX];
int n,m,s;

void DFS(int w,int ID)
{
	int len;
	visited[ID]=1;
	w+=weight[ID];
	if(w>s)
		return;//權重大於S,直接返回
	else if(w==s&&adjoin[ID].size()==0)//權重等於S,並且為葉子節點
	{
		path.push_back(weight[ID]);
		printf("%d",path[0]);
		len=path.size();
		for(int i=1;i<len;i++)
			printf(" %d",path[i]);
		printf("\n");
		path.pop_back();
	}
	else if(w<s&&adjoin[ID].size()>0)
	{
		int maxweight=0,maxid=0;
		path.push_back(weight[ID]);
		while(maxid!=-1)
		{     
			maxweight=maxid=-1;
			for(int i=0;i<adjoin[ID].size();i++)//從該節點孩子中權
			{	                            //重最大的開始搜尋
				if(!visited[adjoin[ID][i]]&&weight[adjoin[ID][i]]>maxweight)
				{
					maxweight=weight[adjoin[ID][i]];
					maxid=adjoin[ID][i];
				}
			}
			if(maxid!=-1)
			{
				visited[maxid]=1;
				DFS(w,maxid);
			}
		}
		path.pop_back();
	}
	return;
}

int main(int argc,char *argv[])
{
	int i,j,k;
	int ID,child;
	scanf("%d%d%d",&n,&m,&s);
	for(i=0;i<n;i++)
		scanf("%d",&weight[i]);
	for(i=0;i<m;i++)
	{
		scanf("%d%d",&ID,&k);
		for(j=0;j<k;j++)
		{
			scanf("%d",&child);
			adjoin[ID].push_back(child);
		}
	}
	DFS(0,0);

	return 0;
}