HDU 2039 三角形(水~)
阿新 • • 發佈:2019-02-17
Description
給定三條邊,請你判斷一下能不能組成一個三角形
Input
輸入資料第一行包含一個數M,接下有M行,每行一個例項,包含三個正數A,B,C,其中A,B,C <1000
Output
對於每個測試例項,如果三條邊長A,B,C能組成三角形的話,輸出YES,否則NO
Sample Input
2
1 2 3
2 2 2
Sample Output
NO
YES
Solution
水題
Code
#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
int t;
cin>>t;
while(t--)
{
double a,b,c;
cin>>a>>b>>c;
if(a+b>c&&a+c>b&&b+c>a)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}